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 Microsoft Office Button 

 The Microsoft Office Button is in the top left corner of the 

window and provides access to open, save, and print documents. 

 Click on the Microsoft Office Button and then click on the desired option. 

 Menu options with an arrow have additional choices available in the area to the right. 

 The Excel Options button at the bottom of the window allows the user to make 

adjustments to Excel such as color scheme, workbook options, formula options, and 

spelling. 

Quick Access Toolbar 

 The Quick Access Toolbar is just to the right of the Microsoft Office Button. 

 When the cursor is over a button, the name of the button is displayed. 

 The options available when Microsoft Office 2007 is first installed include Save, Undo, 

and Redo. 

Customizing the Quick Access Toolbar 

 To add an item, click on the Customize Quick Access Toolbar drop down arrow at the 

end of the Quick Access Toolbar and click on the desired item. 

 Options with a check mark in front of them are displayed on the Quick Access 

Toolbar. 

 To remove a button, click on the Customize Quick Access Toolbar drop down 

arrow at the end of the Quick Access Toolbar and click on the desired item. (This 

removes the checkmark from in front of the item.) 

 To add a command button from the Ribbon, right click on the desired command 

button and choose Add to Quick Access Toolbar. 

 To remove a command button that has been added to the Quick Access Toolbar, 

right click on the button on the Quick Access Toolbar and choose Remove from 

Quick Access Toolbar.  

Changing the order of the Buttons on the Quick Access Toolbar 

 Click on the Customize Quick Access Toolbar drop down arrow at the end of the Quick Access 

Toolbar and choose More Commands…. 

 In the column on the right below Customize Quick Access Toolbar, click on the item to be 

moved. 

 To move the item up, click on the up arrow at the right. 

 To move the item down, click on the down arrow at the right. 

 Click on OK. 

Position of the Quick Access Toolbar 

 The Quick Access Toolbar is usually located to the right of the Microsoft Office Button.  

 To place the Quick Access Toolbar below the Ribbon, click on the Customize Quick Access Toolbar 

drop down arrow and choose Show Below the Ribbon. 

 To place the Quick Access Toolbar back next to the Microsoft Office Button, click on the Customize 

Quick Access Toolbar drop down arrow and choose Show Above the Ribbon. 
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The Ribbon 

 
 The Ribbon runs across the top of the window. 

 The Ribbon consists of 3 types of items. 

o Tabs – This is the main level and includes Home, Insert, Page Layout, etc. 

o Groups – Each tab has several groups that show related items together. 

o Commands – A command is a button in a group or an item in a list. 

 Some tabs are only available when a particular item is selected. For example, the Picture Tools tab is only 

shown when a picture is clicked on. 

Using the Ribbon 

 Click on the desired tab. 

 The commands under each tab are grouped. The name of the group is at the bottom. 

 Some groups have a Dialog Box Launcher button which opens the dialog box with more commands. 

Minimizing/Restoring the Ribbon 

 To minimize the Ribbon, click on the Customize Quick Access Toolbar drop down arrow and choose 

Minimize the Ribbon (a checkmark is now displayed in front of Minimize the Ribbon)  

o OR double click on the currently selected tab on the Ribbon. 

 To display the Ribbon, click on the Customize Quick Access Toolbar drop down arrow and choose 

Minimize the Ribbon (the checkmark in front of Minimize the Ribbon is removed.)  

o OR double click on the currently selected tab on the Ribbon. 

Keyboard Shortcuts 

 Press the Alt key on the keyboard to display the keystrokes for the tabs and Mini toolbar. 

 Press the desired key such as H for the Home tab. 

 Continue pressing the indicated keys and/or down arrow to make the desired choices. 

 To remove the keystroke markers from the screen, press the Alt key. 

Help 

 Click on the Microsoft Office Excel Help button in the top right corner. 

 Type the desired word in the search box and then press the Enter key. 

 Choose the desired topic from the ones displayed. 

 To research another topic, enter the desired word in the search box 

and then press the Enter key. 

 Note – An active Internet connection will find more results. 

Opening a Document 

 Click on the Microsoft Office Button and then click on Open. 

 Navigate to the location of the desired file. 

o (Optional) Click on the Views button and choose Large Icons, Small Icons, List, Details, 

Properties, Preview, or Thumbnails. 

 Choose the name of the file to work with and click on the Open button. 
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Converting Older Excel Documents 

 Microsoft Office 2007 can open documents created in all previous versions of Excel. Previous versions will 

be opened in compatibility mode. (You will know if a document has been opened in compatibility mode 

because it will say “compatibility mode” next to the name of the file on the title bar.) 

 Documents that have been opened in compatibility mode may not have the same features on the Ribbon as 

documents created in or converted to the Microsoft Office 2007 version, i.e. instead of SmartArt Graphics, 

it may be Design Gallery objects. 

 Documents created in previous versions of Microsoft Office can be converted to the Microsoft Office 2007 

version. An advantage for converting documents to the newest version is that it will give you access to all 

the new features.  

 To convert an open document: 

o Click on the Microsoft Office Button and choose Convert. 

o Click on OK. 

Spreadsheet Anatomy 

Parts of a spreadsheet 

 Cell - The box where the numbers, the labels, or the formulas are entered. 

 Column - The collection of cells in a line from top to bottom. 

 Row - The collection of cells in a line from side to side. 

 Worksheet - The single page of rows and columns that is on the screen. 

 Workbook - The collection of pages (worksheets) that make up one file. 

 Range - A group of cells that are next to each other. 

 Mouse pointer - The arrow or other marker that indicates where the mouse is pointing.  

 Formula - A mathematical expression that gives instructions to the computer about what to do with the 

contents of specified cells. 

Size of the Spreadsheet 

 Each sheet has over 15,000 columns ( A to XFD) and 1,000,000 rows. 

 Each workbook can have over 3,000 sheets. The exact number is dependent upon the amount of memory in 

the computer.  

Navigating in the Worksheet Window 

 Enter key - Moves down one cell. 

 Tab key - Moves across one cell to the right. 

 Shift Enter - Moves up one cell. (Reverse gear) 

 Shift Tab - Moves across one cell to the left. (Reverse gear) 

 Arrow keys - Move one cell in the direction of the arrow. 

 Control  or Control  - Moves to the next cell with information or to the far edge of the worksheet. 

 Page Up and Page Down - Move one full screen at a time up or down through the worksheet. 

 Control Page Up and Control Page Down - Moves from worksheet to worksheet. 

 Scroll Bars 
o The Scroll Bar on the right side moves the screen up or down. 

o The Scroll Bar on the bottom right moves the screen to the right or left. 

 Home key - Sends the cursor to the first column (A). 

 Control Home - Sends the cursor to cell A1. 

 Control End - Sends the cursor to the bottom right of the spreadsheet. 
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Views 

Zoom Box 

 On the Ribbon, click on the View tab. 

 In the Zoom group, click on the Zoom button. 

 Choose a percentage 

 OR click in the Custom box, and type the desired percentage.  

 Click on OK. 

 OR use the Zoom toolbar on the Status Bar at the 

bottom right corner of the window. 

Zoom to Selection 

 Click and drag to highlight the area of the desired spreadsheet. 

 On the Ribbon, click on the View tab. 

 In the Zoom group, click on the Zoom to Selection button. 

Zoom to 100% 

 On the Ribbon, click on the View tab. 

 In the Zoom group, click on the 100% button. 

Working with Cells 

Seeing what is in a cell 

 Click in the cell. 

 Look at the Input Line. 

 Note - A formula will have an = sign followed by numbers, cell names, etc. 

Changing Information in a Cell 

 Click in the cell to be changed. 

 Type in the new information. 

 Note – The new information replaces the old information.  

 To make a change without losing the original information, click on the Input Line below the toolbars and 

make the desired changes 

 OR double click in the cell and make the desired changes. 

 Press the Enter key. 

Undo/Redo 

 To undo the last action, on the Quick Access Toolbar, click on the Undo button. 

 To bring back the last undo, on the Quick Access Toolbar, click on the Redo button. 

 To see the undo history, click on the down arrow next to the button. 

 To perform multiple undo’s, click on the Undo down arrow and click on the desired item in the list. The 

action clicked on and all others above it in the list will be undone. 

 Undo’s can be done even past the point of the last save, but not if the file has been closed. 

 The number of undo’s is limited. 

o The greatest number of undo’s possible is 100. 

o Some operations limit the number of undo’s and some operations, such as macros, do not allow 

any undo’s after they are performed. 

 Press the Esc key to undo from what was being entered in a cell.  
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Filling in a Form 

 Open the desired form. 

 Find the appropriate cell and enter the information. 

Forecasting with a Spreadsheet  

Steps to Follow 

 Enter the information to indicate a possible situation. 

 Print a copy and/or save the file. 

 Enter the information for another possible situation. 

 Print a copy and/or save the file. 

 Continue this process until several possibilities have been entered. 

 Enter new numbers for other possibilities. 

Working with Lists 

Structure of a List 

 The first row should be the labels for the fields of information. 

 Don’t have a blank row after the labels. 

 Don’t have a blank row separating information in the list. 

 Don’t have a blank column separating information in the list. 

Information in a List 

 The first row should be the field names. 

 Each column contains information for a field. 

 Each row contains the information for a record. 

Simple Sorting 

 Click in the column to be sorted.  

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Sort A to Z or Sort Z to A. 

Custom Sorting 

 Click in the list. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Custom Sort…. 

 Click on the down arrow of the Sort By box and choose the field to sort by. 

 Click on the down arrow of the Sort On box and choose Values. (Other choices include Cell Color, Font 

Color, or Cell Icon.) 

 Click on the down arrow of the Order box and choose A 

to Z or Z to A. 

 Click on the Add Level button to add the next field to be 

used in the sort. 

 Choose the desired field to sort by, values to sort on, and 

the desired order of the sort.  

 Add or delete levels to the sort as needed. 

 If the list does not have a header row with names for the fields, be sure to remove the checkmark from My 

data has headers at the top of the window. 

 Click on OK. 
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Filter 

 Click in the list. 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Filter. 

 Click on the down arrow of the column to be filtered. 

 Choose from the list the items to be displayed. 

 Click on OK. 

Changing the Filter 

 Click on the filter button at the top of the column. 

 Choose from the list the items to be displayed. 

 Click on OK. 

Clearing a Filter 

 Click on the filter button at the top of the column. 

 Click on Clear Filter From “------“. 

Showing Items with Blank Cells 

 Click in the column to be filtered. 

 Click on the button at the top of the column. 

 Click to remove the checkmark from Select All. 

 Scroll to the bottom of the list and choose Blanks. 

 Click on OK. 

Showing All of the Information 

 Click on the filter button at the top of the column. 

 Click in the Select All box. 

 Click on OK. 

Turning Off the Filter 

 On the Ribbon, click on the Home tab. 

 In the Editing group, click on the Sort & Filter button and choose Filter. 
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Creating a new spreadsheet 

Plan  

 What should the spreadsheet accomplish? 

 What should be on this spreadsheet? 

 What should the spreadsheet do with the information? 

 What information must be on the spreadsheet to get the desired results? 

 Sketch out a picture of the spreadsheet. Where will things be? 

 

M & M Survey 

First Name Last Name Yellow Red Orange Blue Green Brown Total 

James Adams 2 2 3 4 4 9 24 

Ann Brady 2 5 1 3 1 12 24 

Paul Murphy 2 3 6 3 3 6 23 

 Totals 6 10 10 10 8 27 71 

  Yellow Red Orange Blue Green Brown Total 

 Averages 2.0 3.3 3.3 3.3 2.7 9.0 23.7 

Rows and Columns 

Inserting a Row 

 Click in the row where the new row is to be placed. 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Insert button down arrow and choose Insert Sheet Rows. 

 Note – Highlighting several rows causes that number of rows to be inserted. 

Deleting a Row 

 Click in the row to be deleted. 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Delete button down arrow and choose Delete Sheet Rows. 

 Note – Highlighting several rows causes that number of rows to be inserted. 

Inserting a Column 

 Click in the column where the new column is to be placed. 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Insert button down arrow and choose Insert Sheet Columns. 

 Note – Highlighting several columns causes that number of columns to be inserted. 

Deleting a Column 

 Click in the column to be deleted. 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Delete button down arrow and choose Delete Sheet Columns. 

 Note – Highlighting several columns causes that number of columns to be inserted. 
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Fill 

Getting the Months or Days of the Week in Quickly 

 Click in the first cell. 

 Type in the first month or day desired. 

 Place the cursor over the Fill Handle. 

 Click and drag over the cells where the rest of the 

months or days of the week are to be filled in. 

Filling in Text 

 Click in the cell with the text. 

 Click on the Fill Handle and drag the cursor over the cells to be filled. 

 The text is copied into the cells. 

Filling in Formulas 

 Click in the cell with the formula. 

 Click on the Fill Handle and drag over the cells. 

 The formula is copied into the cells. 

Filling with a Number Pattern 

 Enter the first two or three numbers in the cells. i.e. 1, 2, 3. 

 Highlight the cells with the numbers. 

 Click on the Fill Handle and drag over the cells where the pattern is to be continued. 

o Drag down or to the right to increase the number sequence. 

o Drag up or to the left to decrease the number sequence. 

Merging and Centering the Title 

 Click and drag to highlight the title and the cells it should cover. 

 On the Ribbon, click on the Home tab. 

 In the Alignment group, click on the Merge and Center button. 

 Note – To undo merging and centering, repeat the steps above. 

Centering the Heading of a Column 

 Click in the cell. 

 On the Ribbon, click on the Home tab. 

 In the Alignment group, click on the Center button. 

Formatting Text 

 Highlight the cells to be formatted. 

 On the Ribbon, click on the Home tab. 

 The Alignment group contains buttons for justifying the text to the left, 

center, or right. 

 The Font group contains buttons for choosing the font, font size, increasing the font size, decreasing the 

font size, changing the font color, etc. 

 Click on the desired button. 

 Note – By clicking on the Font down arrow of the Font Size down 

arrow and resting the cursor over the desired choice, the selected text 

changes to preview the effect of the choice. 

The Fill Handle is the little 

black square at the bottom right of a group of 

highlighted cells. 
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Mini toolbar 

 The Mini toolbar is a semi-transparent toolbar which appears when text is selected. 

 Highlight text to be formatted. 

 Use the buttons on the Mini toolbar to make the desired changes to 

the text. 

 If the Mini toolbar has disappeared, right click on the highlighted text to bring up the Mini toolbar. 

Rotate the Text 

 Highlight the cells. 

 On the Ribbon, click on the Home tab. 

 In the Alignment group, and click on the Orientation button. 

 Choose the desired rotation from the list. 

Column Width and Row Height 

Fixing Column Width 

 On the Column Indicator, double click on the line to the right of the column letter to be adjusted. 

 OR click and drag the line to the right of the column letter to the desired width 

Fixing Row Height 

 On the Row Indicator, double click on the line below the row number to be adjusted. 

 OR click and drag the line under the row number to the desired height. 

Adding Borders to a Block of Cells 

 Highlight the block of cells to be formatted. 

 On the Ribbon, click on the Home tab. 

 In the Font group, click on the down arrow next to the Border button and 

choose the desired border. 

Customized Borders 

 Highlight the block of cells to be formatted.  

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Format button and choose 

Format Cells…. 

 Click on the Border tab.  

 In the Line section, click on the desired line style. 

 In the Line section, click on the down arrow of the Color 

box and choose the desired color. 

 Click on the Border buttons to place the border around the 

cells. 

 Click on OK. 

Shading a Block of Cells 

 Highlight the block of cells. 

 On the Ribbon, click on the Home tab. 

 In the Font group, click on the down arrow next to the Fill Color button. 

 Click on the desired color. 

 Note – Rest the cursor over a color and a preview of the color in the block of cells is displayed. 
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Gradient Shading 

 Highlight the block of cells. 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Format button and choose Format Cells…. 

 Click on the Fill tab. 

 Click on the Fill Effects button. 

 In the Colors section, choose the desired colors. 

 In the Shading styles section, choose the desired style. 

 In the Variants section, click on the desired shading. 

 Click on OK. 

 Click on OK. 

Patterns 

 Highlight the block of cells. 

 On the Ribbon, click on the Home tab. 

 In the Cells group, click on the Format button and choose Format 

Cells…. 

 Click on the Fill tab. 

 Click on the Pattern Style down arrow and choose the desired style. 

 Click on the Pattern Color down arrow and choose the desired color. 

 Click on OK. 

Formatting Numbers 

 Highlight the cells to be formatted. 

 On the Ribbon, click on the Home tab. 

 In the Number group, click on the Number Format button and choose the desired format.  

o $ for Currency 

o % for Percentage 

o , to add a comma separating periods (hundreds, thousands, millions, etc.) 

o  to increase the number of decimals. 

o  to decrease the number of decimals. 

 OR click on one of the formatting buttons. 

 Click on OK. 

Number Formats 

 General - Cells have no specific number format. 

 Number - Use for general display of numbers. 

 Currency - Use for general monetary values. 

 Accounting - Lines up currency symbols and decimal places in a column. 

 Short Date - Displays the date in number format. 

 Long Date - Displays the date written out with the day of the week, month, date, and year. 

 Time - Displays the time in the selected format. 

 Percentage - Multiplies the cell value by 100 and displays with a percent symbol. 

 Fraction - Displays as a fraction with rounding to halves, quarters, eighths, sixteenths, or tenths. 

 Scientific - Displays in scientific notation. 

 Text - Sets to text format (label). 

 Special – Displays special formats for Zip Code, Phone Number, or Social Security Number. 
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Pictures 

Inserting a  Picture from Clip Art 

 Click in the document where the picture should be placed. 

 On the Ribbon, click on the Insert tab. 

 In the Illustrations group, click on Clip Art. 

 In the Clip Art pane, type a word in the Search text: box and click on the Go button.  

 If a message appears asking if pictures should be included from the Microsoft site, click on the Yes button. 

o Note – An active Internet connection is required to see clipart from the Microsoft site. 

 Scroll through the collection and find the desired picture. 

 Click on the desired picture. 

Inserting a Picture from Files 

 Click in the document where the picture is to be placed. 

 On the Ribbon, click on the Insert tab. 

 In the Illustrations group, click on Picture. 

 Navigate to the location of the picture. 

 Click on the desired picture. 

 Click on the Insert button. 

Rotating the Picture 

 Double click on the picture.  

 The Format tab of Picture Tools comes up on the Ribbon.. 

 In the Arrange group, click on the Rotate button and choose the desired rotation. 

 OR click on the green dot above the picture and drag the picture to the desired 

angle. 

Resizing a Picture 

 Click on the picture. 

 Move the cursor over a corner. (The cursor changes to a two-headed arrow.) 

 Click and drag to the desired size. 

Deleting a Picture 

 Click on the picture. 

 Press the Delete key on the keyboard. 

Moving and  Copying 

Cut and Paste 

 Highlight the cell or cells to be moved. 

 Press Ctrl X 

 OR on the Ribbon, click on the Home tab. 

o In the Clipboard group, click on the Cut button. 

 Notice the marching ants around the block you are cutting. 

 Click in the cell where the information is to be moved. 

 Press Ctrl V 

 OR on the Ribbon, click on the Home tab. 

o In the Clipboard group, click on the Paste button. 
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Copy and Paste 

 Highlight the cell or cells to be moved. 

 Press Ctrl C 

 OR on the Ribbon, click on the Home tab. 

o In the Clipboard group, click on the Copy button. 

 Notice the marching ants around the block you are cutting. 

 Click in the cell where the information is to be copied. 

 Press Ctrl V 

 OR on the Ribbon, click on the Home tab. 

o In the Clipboard group, click on the Paste button. 

Moving a block of cells 

 Highlight the cells to be moved. 

 Place the cursor in the anchor cell (top left corner of group) on the top 

border of the cell.  

 The cursor changes to a four-headed arrow. 

 Click and drag the block of cells to the desired location. 

Clearing a block of cells 

 Highlight the cells to be cleared. 

 Press the Delete key. 

Freeze Pane 

 Click in the cell just under and to the right of the information that shouldn’t scroll off the screen. 

 On the Ribbon, click on the View tab. 

 In the Windows group, click on the Freeze Panes button and choose Freeze Panes. 

Unfreeze Panes 

 On the Ribbon, click on the View tab. 

 In the Windows group, click on the Freeze Panes button and choose Unfreeze Panes. 

Formulas 

Entering Simple Formulas  

 Click in the desired cell.    

 On the Ribbon, click on the Formulas tab. 

 In the Function Library group, click on the down arrow to the right of the Auto Sum button. 

 Choose the appropriate function. 

o Sum - Add the list of numbers. 

o Average - Find the mean of the list of numbers. 

o Count Numbers - Count the number of cells with numbers. 

o Max - Find the maximum (largest) number in the list. 

o Min - Find the minimum (smallest) number in the list. 

 Note – The marching ants indicate the cells included in the formula. 

o If needed, click and drag to highlight the desired cells for the formula. 

o Do not include the cell with the formula in the selection. 

 Press the Enter key. 
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Writing a Formula  

 Click in the desired cell. 

 Type an equals sign (=). 

 Select the cell, then type the operation, and repeat as needed. 

o The operations could include:

 Addition (+) 

 Subtraction (-) 

 Multiplication (*) 

 Division (/) 

 Exponentiation (^) 

 Press the Enter key to finish. 

Worksheets 

Naming a Worksheet 

 Double click on the tab of the sheet. 

 Enter a name for the sheet. 

 Press the Enter key. 

Copying a Worksheet 

 Hold down the Control key. 

 Click on the tab of the sheet and drag it to the right. 

 Notice the black arrow indicating where the sheet will be placed. 

 Let go of the mouse at the desired location. 

 Let go of the Control key. 

Moving a Worksheet 

 Click on the tab of the sheet and drag it to the desired location. 

Coloring the Worksheet Tab 

 Right click on the tab of the sheet. 

 Place the cursor over Tab Color and click on the desired color. 

 Note – When the tab is selected, the color shows at the bottom. When the tab 

is not selected, the entire tab shows the color. 
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Creating a Chart 

 Select the data for the chart. 

 On the Ribbon, click on the Insert tab. 

 In the Charts group, click on the desired type of chart and 

choose the desired chart format. 

 

 

Changing the Chart Type 

 Click on the chart to select it. 

 Click on the Design tab of Chart 

Tools. 

 In the Type group, click on the 

Change Chart Type button.  

 Click on the desired chart type in the list on the 

left. 

 Choose the desired chart subtype on the right. 

 Click on OK. 

Switching Rows and Columns 

 Switching rows and columns changes the way the 

data is represented on the chart. 

 Click on the chart to select it. 

 Click on the Design tab of Chart Tools. 

 In the Data group, click on the Switch Row/Column button.  

  

Types of Charts 

Name Description 

Column Use to compare totals over time and to show a trend. 

Line Use to show change over time, emphasizing the rate of change. 

Pie Use to show relationships and portions of the whole. 

Bar Use to compare totals over time and to show a trend. 

Area Use to show change over time, emphasizing the amount of change. 

Scatter Use to compare trends over uneven intervals of time. 

Other These include Stock, Surface, Doughnut, Bubble, and Radar. 
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Changing the Data Selection  

 The data to be included in the chart can be changed. 

 Click on the chart to select it. 

 Click on the Design tab of Chart Tools. 

 In the Data group, click on the Select Data button.  

 Click on the button at the end of the Chart data range box. 

 Click and drag in the spreadsheet to select the desired data. 

 Note – The chart changes as the data is selected. 

 Click on OK. 

Changing the Chart Layout  

 Click on the chart to select it. 

 Click on the Design tab of Chart Tools. 

 In the Chart Layouts group, click on the More button.  

 Click on the desired layout. 

Changing the Chart Style  

 Click on the chart to select it. 

 Click on the Design tab of Chart Tools. 

 In the Chart Styles group, click on the More button.  

 Click on the desired style. 

Changing the Chart Location  

 The chart can be a picture floating on top of the 

worksheet, or a separate worksheet. 

 Click on the chart to select it.  

 Click on the Design tab of Chart Tools. 

 In the Location group, click on the Move Chart button.  

 Click on the desired location. 

 Click on OK. 

Chart Title  

 Click on the chart to select it.  

 Click on the Layout tab of Chart Tools. 

 In the Labels group, click on the Chart Title button and choose the 

desired location. 

 Click in the chart title box on the chart and edit the title as desired. 

Chart Legend  

 Click on the chart to select it.  

 Click on the Layout tab of Chart Tools. 

 In the Labels group, click on the Legend button and choose the desired location. 

Data Labels  

 Data labels place a number in the chart indicating the value of the chart item. 

 Click on the chart to select it.  

 Click on the Layout tab of Chart Tools. 

 In the Labels group, click on the Data Labels button and choose the desired option. 
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Formatting Text in the Chart 

 Click on the chart to select it.  

o Click on the text to be formatted. 

o Click on the Home tab. 

o In the Font group, click on the desired button and make the desired 

change 

 OR click on the chart to select it.  

o Click on the text to be formatted. 

o Click on the Format tab of Chart Tools. 

o In the Shape Styles group, click on the More button. 

o Move the cursor over the different styles and notice the change in the chart. 

o Click on the desired style. 

o In the WordArt Styles group, click on the More button. 

o Move the cursor over the different styles and notice the change in the chart. 

o Click on the desired style. 

Spelling 

 On the Ribbon, click on the Review tab. 

 In the Proofing tab, click on the Spelling button. 

 Check each word that comes up. 

 Click on Ignore or Ignore All button to make no 

changes. 

 Click on the correct spelling and then click on the Change 

button. 

 

Saving a Workbook 

 Click on the Microsoft Office Button and then click on Save As. 

 Check the name of the document and make changes 

as needed. 

 By default, Excel saves documents to the My 

Documents folder. 

 Check to see where the document is being saved. 

 If the spreadsheet is not to be saved in the current 

location, click on the down arrow of the Save In 

box and choose the desired location. 

 Click on the Save button. 

Saving the Worksheet to a Previous Version 

 Click on the Microsoft Office Button and then 

click on Save As. 

 Give the spreadsheet a name. 

 Click on the down arrow at the end of the Save as type: box. 

 Choose the version of Excel to be used. 

 Click on the Save button. 
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Printing 

 Always look at the document in Print Preview first! 

Print Preview 

 Click on the Microsoft Office Button and choose Print  Print Preview. 

 Look carefully at the page to see what needs to be done. 

Page Setup 

 In the Print group, click on the Page Setup button. 

 Page Orientation 
o Click on the Page tab, and choose Portrait or Landscape. 

 Scaling 
o Click on the Page tab, and adjust the scale of the printing. 

 OR Fit to sets the number of pages the 

information will be squeezed onto. 

o Note - Choose the # pages wide and the # pages tall. 

  Margins 
o Click on the Margins tab. 

o In the Center on page section, choose to center the 

information Horizontally and/or Vertically on the page. 

  Header/Footer 
o Click on the Header/Footer tab, and choose from the list by clicking on the down arrow. 

o OR click on the Custom buttons and enter your own. 

 Sheet 
o Click on the Sheet tab, and choose to print or not print the 

gridlines. 

o Choose the order that the pages will be printed. 

 Click on OK. 

Printing 

 Make adjustments to the printout as noted above. 

 Click on the Print button. 

Printing a Chart 

 A chart can be printed so that it fills the paper and does not include the rest of the spreadsheet. 

 Click on the desired chart. 

 Click on the Microsoft Office Button and choose Print  Print Preview. 

 Make the desired adjustments as noted above. 

 Click on the Print button. 

 OR change the chart location to a new sheet and print the sheet. 
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Multiple Page Printouts 

Titles Repeated on Every Page 

 Close Print Preview. 

 On the Ribbon, click on the Page Layout tab. 

 In the Page Setup group, click on the Print Titles button. 

 Click on the Sheet tab. 

 Click on the red arrow at the right of Rows to repeat at top. 

 Click in the row with the headers you want repeated. 

 Press the Enter key. 

 Click on the red arrow at the end of the Columns to repeat at left. 

 Click in the column with the headers you want repeated. 

 Press the Enter key. 

 Click on OK. 

Saving as PDF 

 To save or export a file to PDF, you must first install the Save as PDF add-in from the Microsoft Office 

website. 

o Go to http://www.microsoft.com  

o Type PDF in the search box located in the upper right corner. 

o Click on the result that says: Download details: 2007 Microsoft Office Add-in:… 

o Click on the Continue button next to “Validation required.” 

o After your computer has been validated, click on the Download button. 

o Click on Run. 

o Click on Run. 

o Check the box to Accept the Microsoft Software License Terms. 

o Click on Continue. 

o Click on OK. 

 Once the PDF add-in has been installed to the computer, open the document that needs to be converted to 

PDF. 

 Click on the Microsoft Office Button, place the cursor over Save As…, and click on PDF. 

 Navigate to the location where the PDF document will be saved. 

  (Optional) Type in a file name.  

 Click on the Options button. 

 Make choices in the Options window to determine what part of the 

spreadsheet will be included in the pdf. 

 Click on OK. 

 Click on Save. 

  

http://www.microsoft.com/
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Templates 

 Templates provide the basic format of a document. 

 Click on the Microsoft Office Button and then click on New. 

 The Templates section displays templates 

available on the computer. 

o Choose the category of template desired. 

o Click on the desired template. 

o Click on the Create button. 

 The Microsoft Office Online section connects to 

templates available online from Microsoft. 

o Choose a category and click on the 

desired template. 

o Click on the Download button. 

o The template opens in Word. 

o Note – The document should be saved to 

the computer. 


